No sound from the stereo. - Page 2 - Citroen DS4 Forums
Reply
 
LinkBack Thread Tools
post #11 of 21 (permalink) Old 15th December 2016, 22:44
Junior Member
 
Join Date: Dec 2016
Location: Sn82hl
Posts: 6
mine does the same with the left hand side speakers they seem ok sometimes and sometimes no sound comes out at all any suggestion
ravaszcsibesz is offline  
Sponsored Links
Advertisement
 
post #12 of 21 (permalink) Old 27th December 2016, 17:22
Junior Member
 
Join Date: Aug 2016
Posts: 2
Problem is most likely a defective speaker if u got the Denon Sound System the amplifier will cut the power to all the Speakers.

I got it on mine and had an error code for that stored.
Chris1983 is offline  
post #13 of 21 (permalink) Old 27th December 2016, 21:15
Junior Member
 
Join Date: Dec 2016
Location: Sn82hl
Posts: 6
i have replaced all the speakers and nothing changed still the sound goes on and off and the left hand side speakers are more weaker then the right hand ones. And also the temp sensor does the same sometimes show me the outside temp dometimes dont.
Any suggestion any advice please Help
Help
ravaszcsibesz is offline  
Sponsored Links
Advertisement
 
post #14 of 21 (permalink) Old 28th December 2016, 06:45
DS4 Pro
 
Nicdog's Avatar
 
Join Date: Oct 2016
Location: Sydney
Posts: 479
Hi there,
your describing electrical faults and without a wiring diagram I'm only guessing but I'd say that because the in car display/ entertainment unit is linked to the external temperature sensor, your sensor is probably OK just that it is not been being understood by your faulty cd radio unit. I had a similar problem with my previous Peugeot 307 where the dealer said the entertainment unit was faulty and non repairable.
Sorry to say I replaced it with a more capable Kenwood unit, for a 1/4 the cost of the Peugeot replacement.


Loving my DS4 DSport - 1.6 THP160, EAT6 speed auto, Blanc Nacre

"Most Beautiful Car of the Year, 2013"
Nicdog is offline  
post #15 of 21 (permalink) Old 28th December 2016, 22:29
Junior Member
 
Join Date: Dec 2016
Location: Sn82hl
Posts: 6
Thaks for your reply. I might buy a used radio unit. The trouble is if i buy an aftermarket unit I have to make loads of modifications. I have steering wheel radio controls and loads of stuff like dashboard computer bluetooth which are conneted to the radio.
I am not sure if i buy an aftermarket unit i can keep all these extras

ravaszcsibesz is offline  
post #16 of 21 (permalink) Old 29th December 2016, 03:56
DS4 Pro
 
Nicdog's Avatar
 
Join Date: Oct 2016
Location: Sydney
Posts: 479
Now I think about it, the 307 had some Intermittent issues with electrical bits that was traced back to a cracked fuse box.
Who knows how it cracked as the car was never in an accident but if your up for it...take a good look, really examine the engine bay fuse box for cracks or loose connections.
Unless you've got a covered dry space to work on the DS, I'd say let a qualified garage/dealer track it down for you. They'll know how to isolate areas and narrow down the possibilities. Come back with your findings / the outcome.

Loving my DS4 DSport - 1.6 THP160, EAT6 speed auto, Blanc Nacre

"Most Beautiful Car of the Year, 2013"
Nicdog is offline  
post #17 of 21 (permalink) Old 13th July 2019, 09:20
Junior Member
 
Join Date: May 2019
Posts: 3
did you ever get this fixed?

Hi,

A few months ago i purchased a ds4 , and i have the same audio issues described in this thread. Did you ever get this resolved?

Any info would be greatly appreciated

Thanks
Steve
steveb is offline  
post #18 of 21 (permalink) Old 18th November 2019, 18:29
Junior Member
 
Join Date: Nov 2019
Posts: 1
had the same problem - they fix it

Hi Guys,
after a few years of working/not working sound system, we found the problem and the solution!

History:
My Citroen's DS4 Denon sound system suddenly stopped working while riding on the reverse. ;-). I crashed a little as I was just waiting for the sound :-/. From that time the sound was not working during hot temperature but it was working while freezing weather. Or it suddenly starts working after 30-40 minutes. Half-year ago sound system totally stopped working.

Repair:
I put the car to a dealer to ask him to do everything. I know that they do a very good job. They found out that:

1. the common problem with DS4 is water coming to the rear doors very often
2. the water came to the speaker which short circuit
3. I was very lucky as the amplifier was ok; they told me that it is very often that when the speaker is short circuit, the amplifier can short circuit also!

Radek
rakcz is offline  
post #19 of 21 (permalink) Old 3rd February 2020, 21:30
Junior Member
 
Dr Alcazir's Avatar
 
Join Date: Feb 2019
Location: Midrand, South Africa
Posts: 5
Am a Citroen ds4 2.0 hdi 2015,with Denon sound system... the sound is not there. The dealer replaced the radio, the sound came back and died on the 3rd day. The dealer suspected the amp, now am in south africa, the amplifer has been out of stock for 6 months now in France apparently. So i opted for after market... now the volume cannot be controlled and the sensors are quiet. I have installed 4 channel Jbl amplifyer and sub. Help a lady out please... am frustrated.
Dr Alcazir is offline  
post #20 of 21 (permalink) Old 4th February 2020, 13:52
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 781
What headunit is fitted?

David
vexorg is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Citroen DS4 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome