Xenon headlight highbeam - Citroen DS4 Forums
Reply
 
LinkBack Thread Tools
post #1 of 16 (permalink) Old 7th September 2020, 12:15 Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 24
Xenon headlight highbeam

Hi everyone,
Does anyone have experience with the xexon headlamps. My high beam does not work on one side. It flicked a lot one night l and now does nothing on the drivers side. (passenger side is fine)
It seemed to me like the leads for the high/low solenoid must have been shorting or something. I can get in the back of the unit easily. But can't see any major fault. Does anyone know someone who is experienced in fixing these kinds of things. It's beyond my medoicre tiny electrical wire experience. That and I don't want to put the head lamp in the oven to get the cover off, so suggestions welcome there also.
JamesWheeler is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 7th September 2020, 13:07
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 827
I've been meaning to strip mine down, the passenger high beam on mine sometime flicks off, only on bumpy road and only when the light is pointing fully left.


I can only guess it's a bad connector or almost broken wire if it only does it point left.
Problem is that it happens so infrequently that I forget to check it when I do have time.
Would be good to see inside one beforehand.

David

Last edited by vexorg; 8th September 2020 at 09:12.
vexorg is offline  
post #3 of 16 (permalink) Old 7th September 2020, 14:14 Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 24
Mine did exactly that on the night it failed. Would work with the directional lamps going left. I'm sure it has nothing to do with the humpback bridge earlier that day.

Unfortunately the MOT is due soon. Do we think it'll pass. The best I can see is that main beam has to work in pairs.
JamesWheeler is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 8th September 2020, 09:13
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 827
If it comes on when the car is stationary then it'll pass. The direction only works when moving, part of what's putting me off looking at mine, not sure how to make it point left short of jacking up the front end.

David
vexorg is offline  
post #5 of 16 (permalink) Old 8th September 2020, 12:05 Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 24
No mine doesn't work at all
JamesWheeler is offline  
post #6 of 16 (permalink) Old 8th September 2020, 12:08 Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 24
It's a rubbish screen shot. But that's in the back of the unit. But it's that metal solenoid and the pink and yellow wires that do it. (my wires are broken by my own ham-fistedness) but there is then two tiny leads that come from the other side of the connector to the actual solenoid coil
Attached Images
File Type: jpg Screenshot_20200812_211824_com_1599563222911.android.gallery3d.jpg (632.6 KB, 3 views)
JamesWheeler is offline  
post #7 of 16 (permalink) Old 8th September 2020, 13:59
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 827
Looks like you'll need to dismantle the whole light

David
vexorg is offline  
post #8 of 16 (permalink) Old 9th September 2020, 20:31 Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 24
Yeah just not looking forward to doing that. As best as I can tell I need to heat up the sealant before unclipping the front. Me and plastic clips don't get along. And a replacement unit is pretty expensive
JamesWheeler is offline  
post #9 of 16 (permalink) Old 13th September 2020, 12:40 Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 24
Well it passed the mot. So maybe they don't look too closely at main beam
JamesWheeler is offline  
post #10 of 16 (permalink) Old 14th September 2020, 08:51
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 827
Must have worked when they tested it

David
vexorg is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Citroen DS4 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome