Directional headlights - xenon - problem - Citroen DS4 Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 21st September 2020, 12:14 Thread Starter
Junior Member
 
Join Date: Nov 2017
Location: Poland
Posts: 7
Directional headlights - xenon - problem

Hello everyone

I've been struggling for couple of weeks with headlight of my 2012 DS4.



Left headlight doesn't work on high beam, it's flickering. I thought that the reason was the bulb itself, so I switched them, I took the one from right side and put them into the "flickering" headlight but it didn't change anything. The bulb from left side was working fine (both on low and high beam) on the right side and the bulb from right headlight flickered on the left. Then I switched the ballast from one side to another, same result.


And then I found out, that the problem is the directional headlights mechanism. When I drive straight or turn right the left headlight doesn't work on high beam (low beam is OK). When I start to turn left it turns on and works fine. So there must be something wrong with this directional system. But what could be the case? Broken wire? Bad connection somewhere? Shorting? Is steering wheel sending any signals to the light? Maybe there's a problem? As you know getting inside the headlight itself requires dismantling it completely. Is there any other way of fixing it?


Thanks for any advice.
Luk77 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 21st September 2020, 13:57
Member
 
Join Date: Nov 2018
Posts: 35
Hi,

If is the same problem as mine has I expect is the little wires inside the unit that feed the high/solenoid. But aside from having someone take the headlight apart and fix the tiny wires inside I don't know how to fix it. I haven't found anyone to do this for mine yet.
JamesWheeler is offline  
post #3 of 5 (permalink) Old 21st September 2020, 15:43
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 850
As far as I know there is only one bulb and the high beam is a mechanical shutter.

David
vexorg is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 21st September 2020, 16:24
Member
 
Join Date: Nov 2018
Posts: 35
I mistyped earlier. I did mean the little wires that feed the high/low solenoid. That being the thing that moves the high beam shutter
JamesWheeler is offline  
post #5 of 5 (permalink) Old 29th September 2020, 20:49 Thread Starter
Junior Member
 
Join Date: Nov 2017
Location: Poland
Posts: 7
So the story continues...
I found couple of workshops that solve problems with headlights and they gave me an advice. I also received advices from another forums. The advices were that I should have changed the wire connector between the bulb and the ballast. It's not an easy task, but I managed to take those wires from both headlights and swapped them, the one from the right, the good headlight went to the left one. As I turned the engine on and switched the high beam I was happy... for three seconds. And then it started to flicker back again. And the right headlight works just fine with the wire from the left side.

So I'm thinking that there must be something wrong with directional headlight mechanism, what else could it be?

Now my plan is to take this headlight to one of those workshops, the have to "unglue" it and dismantle, maybe they can fix it. It' my last hope.
Luk77 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Citroen DS4 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome