Need help with a rattle - Citroen DS4 Forums
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 7th October 2020, 15:37 Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 4
Need help with a rattle

Hi,

I'm pulling my hair out trying to find a metallic rattling/rumble sound from the front near side. Not affected as such by speed bumps etc but more road surface i.e monoblock or rough road surface.

2014 DS4 1.6 THP 200

I have:

- Replaced strut top
- Replaced drop down link
- Replaced lower ball joint
- Replaced wish bone with all new bushes
- Replaced gearbox mount
- Inspected anti roll bushes and all subframe bolts (all look ok)
- Inspected spring and shock (all look ok)

Has anyone else had experience of a rattle that could help shed some light on it for me?

Cheers
Jax09 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 7th October 2020, 16:56
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 850
Brake disc shield? or pads

David
vexorg is offline  
post #3 of 7 (permalink) Old 7th October 2020, 17:19 Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 4
Quote:
Originally Posted by vexorg View Post
Brake disc shield? or pads
I had to remove and refit the shield to do the lower ball joint and the pads looked pretty healthy... So can probably eliminate them.
Jax09 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 7th October 2020, 19:24 Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 4
Can't seem to edit my original post but it's more of a metal clunking/rattling as if something is loose... If that helps 😂
Jax09 is offline  
post #5 of 7 (permalink) Old 11th October 2020, 13:36
Junior Member
 
Join Date: Oct 2020
Posts: 1
Hi

I have exactly the same problem from the nearside front wheel area. I have checked everything. I have replaced the drop links thinking it was this but it isn't. Everything else is nice and tight as it should be. It is far more prevalent when I go around a roundabout and the surface is a little rough. On the motorway I get nothing, all is as it seems. The only thing I haven't checked at this time is the strut upper mount as when I lifted the bonnet I closed it again straight away

Only done 1400 miles since its last MOT in December 2019

Going in for a service and check this week as virtually every warning light has suddenly come on and hope they can rectify this and the knocking noise.

If you do get a fix for it please let me know and vice versa

best regards
Rembos is offline  
post #6 of 7 (permalink) Old 11th October 2020, 15:19 Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 4
Quote:
Originally Posted by Rembos View Post
Hi

I have exactly the same problem from the nearside front wheel area. I have checked everything. I have replaced the drop links thinking it was this but it isn't. Everything else is nice and tight as it should be. It is far more prevalent when I go around a roundabout and the surface is a little rough. On the motorway I get nothing, all is as it seems. The only thing I haven't checked at this time is the strut upper mount as when I lifted the bonnet I closed it again straight away

Only done 1400 miles since its last MOT in December 2019

Going in for a service and check this week as virtually every warning light has suddenly come on and hope they can rectify this and the knocking noise.

If you do get a fix for it please let me know and vice versa

best regards
Yeah I thought it was the strut top as well and when I removed the old one it was split (see pic). However a new one still never cured the rumble.

It has been doing it for about a year and it passed it's last MOT when I was actually hoping for a fail so I knew what to fix. It's in next week again for an Mot and I fear it will pass again lol.

I bought a track rod end and had intended to fit it yesterday but on closer inspection there's nothing wrong with the current one so I never changed it and taking the new one back. Getting fed up now changing parts that don't need changed lol.

Anyways good luck and I'll be sure to let you know if I ever figure it out.
Attached Images
File Type: jpg 20200820_121328_1602425863856.jpg (607.4 KB, 4 views)
Jax09 is offline  
post #7 of 7 (permalink) Old 11th October 2020, 17:35
Super Moderator
 
vexorg's Avatar
 
Join Date: Apr 2017
Posts: 850
Weird, I like putting new parts on even if they are not needed

David
vexorg is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Citroen DS4 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome