Citroen DS4 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Has anyone had the above error message?I obviously stopped the vehicle when it came on but when I turned the engine back on it came up with Engine fault, repair needed message - then shortly after the original error message came back up. I needed to get home (10PM with a 6 year old, only 5-10 mins from home) so I carried on and just two corners (10 seconds away), as I cornered anti roll back error came on then abs error, but only I cornered. They came and went too fast round the first corner and I watched the display the seance corner and just caught them. Up until now this car has been 100% perfect with no issues so I'm not too sure if I should be very concerned or not given it's track reliable record. 62 plate which I've owed since Oct 2015, ex-motability car.
I'll be taking it into Citroen probably Tuesday, my only opportunity but wondered if anyone else had encountered this and could suggest any self fixes?
 

·
Registered
Joined
·
1 Posts
Hi, I know now it's 4 years later, hope you still see this message and can help. How did you sort this issue?
I just had the same exact issue and I believe the problem is the alternator belt and belt tensioner as they are not letting the alternator giving enough constant output to recharge the battery.
All the other error about ABS, Steering, brake etc.. I think are due to the fact that there is no enough electric power in the car to make things work. I connected a tester to my battery and as I was pushing the tensioner onto the belt (although it was squeaking) the battery volt started going up slowly, indicating that the alternator works.
I ordered the belt and belt tensioner and will fit them in a few days and see how it goes.
Hope you can let me know how you sorted it.
Thanks
 

·
Registered
Joined
·
1 Posts
Hi, I know now it's 4 years later, hope you still see this message and can help. How did you sort this issue?
I just had the same exact issue and I believe the problem is the alternator belt and belt tensioner as they are not letting the alternator giving enough constant output to recharge the battery.
All the other error about ABS, Steering, brake etc.. I think are due to the fact that there is no enough electric power in the car to make things work. I connected a tester to my battery and as I was pushing the tensioner onto the belt (although it was squeaking) the battery volt started going up slowly, indicating that the alternator works.
I ordered the belt and belt tensioner and will fit them in a few days and see how it goes.
Hope you can let me know how you sorted it.
Thanks
Hi,
Did you get this issue fixed?
My 2011 DS4 1.6 THP has just had this same issue. ABS/anti roll back, battery charge fault etc. Its holding good charge with engine running. Alternator belt is tight and not slipping.

Any help would be massively appreciated lol.
 

·
Registered
Joined
·
1 Posts
Hi,

I now have this exact problem. I have a 2016 Ds4 Prestige Bluehdi S/S. I enter the vehicle and literally have to push the S/S repeatedly very fast for a few moments which sort of jump starts the engine. I get a half-second sign on the dash - Battery Charge Fault: Stop the vehicle. The issue only happens when the engine has been cooled down, so it's happening first thing in the morning when I need to get to work, and then at the end of the working day after an 8 hour shift. It doesn't happen throughout the day if I am doing a lot of trips.

Again, any help to this issue would be great, especially as we are heading into the darker, colder months. Thank you in advance.
 

·
Registered
Joined
·
205 Posts
First of all I would get the battery tested and see if it ready to be changed, it could be. If it hasn't had a replacement and is the original it could be time.
I would use County Batteries, I don't know if you have one near you.
 

·
Registered
Joined
·
1 Posts
Hi,

I now have this exact problem. I have a 2016 Ds4 Prestige Bluehdi S/S. I enter the vehicle and literally have to push the S/S repeatedly very fast for a few moments which sort of jump starts the engine. I get a half-second sign on the dash - Battery Charge Fault: Stop the vehicle. The issue only happens when the engine has been cooled down, so it's happening first thing in the morning when I need to get to work, and then at the end of the working day after an 8 hour shift. It doesn't happen throughout the day if I am doing a lot of trips.

Again, any help to would be great, especially as we are heading into the darker, colder months. Thank you in advance.
Hi I have had the same fault. Ds4 Bluehdi. Battery fully charged.. no response trying to start. it is not S/S. I have an inexpensive code reader, connecting this, trying to find the code, it wasn't able to connect, turned the ignition off then back on. hey presto all back to normal, following day again no response trying to start. connected code reader, and again back to normal, it runs so well and after the initial start will stop and start all day long with no errors showing. So I have concluded this is a setting fault if it continues as is, then I will tale it to an auto electrician to try and get the code deleted.
has anyone tried this
fforddlast
 
1 - 6 of 6 Posts
Top