Citroen DS4 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi All

We have a DS4 2012 1.6 HDI 110 D Style. We have had the car for just over 2 years and its been perfect other than consumables, tyres etc. It has now developed a fault. The windscreen washers do not work either front or rear. The wiper arms work as normal but no washer pump. I have checked the fuses and the pump itself and all good. I did find a lot of corrosion around fuse 20 ( and surrounding fuses) in the engine compartment fuse box. I have cleaned off the corrosion on the offending fuse and carrier but still no windscreen washers. After some research and a local independent garage looking at it, it seems that water ingress has damaged the fuse box and it needs replacing. Its a common fault apparently. I can purchase the fusebox complete from Citroen for £331 but what i am unclear about is does it need programming to the car. I am receiving conflicting information. Some say its just plug and play and some say it has to be configured.

Just wondering if anyone has experienced the same issue or had to change the fuse box in the engine bay.

The local independent wants £600 to replace the fuse box and its them that said its plug and play. Well if its plug and play i can change it myself.

Any feed back greatly appreciated.

Thanks in advance
 

·
Registered
Joined
·
1 Posts
Hi All

We have a DS4 2012 1.6 HDI 110 D Style. We have had the car for just over 2 years and its been perfect other than consumables, tyres etc. It has now developed a fault. The windscreen washers do not work either front or rear. The wiper arms work as normal but no washer pump. I have checked the fuses and the pump itself and all good. I did find a lot of corrosion around fuse 20 ( and surrounding fuses) in the engine compartment fuse box. I have cleaned off the corrosion on the offending fuse and carrier but still no windscreen washers. After some research and a local independent garage looking at it, it seems that water ingress has damaged the fuse box and it needs replacing. Its a common fault apparently. I can purchase the fusebox complete from Citroen for £331 but what i am unclear about is does it need programming to the car. I am receiving conflicting information. Some say its just plug and play and some say it has to be configured.

Just wondering if anyone has experienced the same issue or had to change the fuse box in the engine bay.

The local independent wants £600 to replace the fuse box and its them that said its plug and play. Well if its plug and play i can change it myself.

Any feed back greatly appreciated.

Thanks in advance
 

·
Registered
Joined
·
222 Posts
Its usually corrosion of the terminals at the fuse box connectors so when you remove the fuse box you can find the connectors on the multi plugs have corroded and require replacement as well. This is often done by buying a multiplug from a written off car and splicing the wires into the loom. I have seen it done but would be wary about doing it myself. Its often caused by the engine compartment being powerwashed - there is a symbol on one of the plastic covers showing a power wash lance with a big cross over it
 

·
Registered
Joined
·
36 Posts
I've just started having similar issues. Now I don't know if it's all related to the same issue but I changed bulbs six months ago to osram night breakers. About 2 months ago the dash display said dipped beam fault and one bulb had gone, so I put in a standard one, a week later the other one went. 2 weeks or so later the heater wouldn't work, no warmth, blowing or noise. It came back a few days later. A month or so passed with no problem, I cleaned the car 2 weeks ago with a pressure washer (bonnet closed, didn't spray engine bay) and since then I've got no heater, no wiper jets and one of the bulbs has gone again yesterday. Does this seem like the fault you describe?

I checked the fuse box and the blades on the #20 fuse were white and showed corrosion.

Any advise please guys??
 

·
Registered
Joined
·
1 Posts
I have exactly the same problem before, need to replace the fuse box (relay module). Parts centre need the VIN to configure it before shipping. DIY after receiving, everything fine now.
 

·
Registered
Joined
·
36 Posts
Have you got a part number for the fuse box(relay module) please or somewhere I can see/source it online
 
1 - 7 of 7 Posts
Top