Citroen DS4 Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
In Sept 2016 I purchased a 65(1yr old) plate DS4 from a Citroen Dealership & the Eco s/s hasn't worked,I return to the Garage after 1week after doing about 100miles & they carried out a battery check & they said it was only 66% charged up & it required 77% to work.I have done over 500 miles in a month now & they checked again & informed it was only 71% charged.Surely the battery should be Fully Charged by now.Most of my trips r local,but I have done one 100mile round trip...Should I just request a New Battery from the Dealership??????
 

·
Registered
Joined
·
544 Posts
500 miles in a month probably won't be enough - it sounds like it needs a couple of good runs to be honest
 

·
Premium Member
Joined
·
937 Posts
Have you a battery charger?
You could try that
Ours didnt work at first, but now does
It does seem that there may be a charging issue though
 

·
Registered
Joined
·
88 Posts
I had the same issue when the battery was less than a year old only had 4000 miles on the clock so mostly short trips.
The battery is only covered for eight Months or 8000 miles.
The dealership had mine on charge overnight and tested,did this twice which showed a battery problem the second time. Citroen replaced it free as a goodwill gesture.
I suggest you ask the dealer to to put yours on charge and test, hope thus helps
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I just returned for the third time to the Citroen Dealership (Pentagon) in Lincoln, as the Eco s/s still isnt working & I have now done over 1500 miles.The readings have gone from 61%,71% & 75% today....The engineer says it needs to be +76% for the ECO 2 work...I was very scepical about this & asked him to check the amperage of the battery & the reading was 530amp..The battery fitted should produce +700amps... So I believe it will be very hard 2 achieve a 76%+ reading 4 the ECO to work.... they have suggested they will take the battery off the car & slow tickle charge over 48hrs.Will this work long term or will it be a quick short term fix ???? I think the best option is a New Battery.....Please Advise me on the best way to approach this problem....
 

·
Premium Member
Joined
·
937 Posts
It should be working by now
I would be speaking to Citroen Customer Services if the Dealer says there isn't a battery problem...There clearly could be!!
 

·
Registered
Joined
·
155 Posts
Had issues with my ds4 years ago with this ( have a look see if you can find the old thread)

Anyway the long and short is a full slow recharge is only a tempery fix.


I got a new battery foc out of Citroen in the end which worked 100%


However had the same issue with my wifes c3 after about 3 years (Also 1.6 ehdi diesel)


My local dealer fixed this with , what they called adjustment of the parameters.


i guess it allowed the start stop to work with a lower charged battery


Before they did that could get it work with trickle charge overnight occasionally (the aldi or lidl electronic car charges are excellent for this)


The problem with those systems is that a a lead acid battery ages it takes longer to fully charge it.


Also lead acid battery's are rubbish when cold, they perform way better when warm


They really should have gone for lithium batteries which can take a quick charge, they would be lighter as well , but i guess the factor is price !!
 

·
Premium Member
Joined
·
937 Posts
Ours isnt working again, despite a long drive to The Lake District and back
There really doesnt appear to be any pattern to it.
Its just random. Surely this cannot be right!!
 

·
Registered
Joined
·
155 Posts
<a href="http://www.ds4ownersclub.co.uk/forum/new-owner_topic284.html%20">http://www.ds4ownersclub.co.uk/forum/new-owner_topic284.html
</a>


have a look though this old post...




All this talk of stop start issues had stopped it working in my c4 now, after 2 1/2 years of working 100%..


But i have been away for a week and only done some local driving.


So i decided to stick on my £13.99 charger from lidl and left it on over night and hay presto its working again










Edited by: g_p_t
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 ·
The DS has been back 2 the dealership for 2days to tickle charge the battery, of the vehicle,they phone 2 say the ECO S/S was working.I am still scepical because it hasn'tworked 4 me yet & there is no recording on the ECO Trip timer (00:00mins) surely it should register everytime the ECO S/S is working!!!!! yes or no ????
 

·
Registered
Joined
·
154 Posts
The ECO Trip Timer resets with every journey, so you won't see a cumulative time over a longer period... I hope the charge the garage gave the battery is enough to get this working for you!
 

·
Registered
Joined
·
1 Posts
In Sept 2016 I purchased a 65(1yr old) plate DS4 from a Citroen Dealership & the Eco s/s hasn't worked,I return to the Garage after 1week after doing about 100miles & they carried out a battery check & they said it was only 66% charged up & it required 77% to work.I have done over 500 miles in a month now & they checked again & informed it was only 71% charged.Surely the battery should be Fully Charged by now.Most of my trips r local,but I have done one 100mile round trip...Should I just request a New Battery from the Dealership??????
Theft is a computer box under the passenger side wing right up in the bulk head that gets water in it stops the stop start working the replacement from Citroen is costly a bout £2000 pounds Citroen o about this but denied this
 
1 - 13 of 13 Posts
Top