Citroen DS4 Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
395 Posts
Discussion Starter · #1 ·
Hi all,Have had a few electronic/electrical problems recently.
Ongoing one is Ice alert function does not work - dealer replaced temp sensor (broke wing mirror glass in process), but still does not work.
Sat nav when adding VIAs on journeys come up with wildly inaccurate ETA times (one was 0.2 miles and it added 24mins, another was 1.0miles and it added an hour!).
Sat Nav screen has also re-booted mid journey on 3 occasions - (completely reboots, losing mapping, music etc until it comes back on - which takes about 2 mins).
Traffic Alert button now says expired when pressed, but there is no explanation as to whther its a chargeable update or not in any manual or website (Sat Nav and SOS/Citroen Assist both do).


It has to be said the dealer in Scunthorpe has no clue on any of these things.


My gut feeling is its a new unit required or at least a complete software rebuild.

Is there anyone out there with similar problems or solutions.
 

·
Registered
Joined
·
551 Posts
I had a few issues with my sat nav not showing POI and some random CD problems and also my traffic alerts had "expired"Took it to the dealers and they did some sort of software update/upgrade and it has worked fine since.
Don't let the dealer fob you off,my dealer had no idea at first but after they got in touch with Citroen boffins they were sent the right fix.
Good luck!
Let us know how you get on.
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #3 ·
Dealer never came back to me had to chase them (Citroen online never replied either). Now they want the car for a day 'to go through with Citroen on phone' . I just hope they resolve this, service so far is 2/10!!
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #4 ·
Update on the electrical saga......

Dealer had car for full day again (bonus was got DS5 to try - see post)
They sent 30 'sessions' to Citroen and spent several hours on phone to them - still got same issues, nothing currently resolved. They are now awaiting Citroen authorising a new Emyway sat nav unit, fingers crossed, hopefully that will resolve all the issues.
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #5 ·
<t></t><table ="tableborder"="" align="center" cellspacing="1" cellpadding="3" style="width: 968px; color: rgb44, 44, 44; font-family: Arial, Tahoma, sans-serif; font-size: 12px; table-layout: fixed;"><t><tr><td rowspan="3" valign="top" ="msgableside"="">
Update 2 on the electrical saga......<div style="font-size: 12px; line-height: 16px;">

<div style="font-size: 12px; line-height: 16px;">After dealer had car for full day at beginning of April and sent Citroen 30 'sessions' and spent several hours on phone to them - three weeks later they want it back as dealer 'needed' to send Citroen MORE codes. WHY?
<div style="font-size: 12px; line-height: 16px;">My sat-nav reboots, and has inaccurate ETAs, my Traffic Alert button does not work, my temp sensor has'nt warned of ice since December!!
<div style="font-size: 12px; line-height: 16px;">I am still awaiting outcome and another month has gone by........
<div style="font-size: 12px; line-height: 16px;">

<div style="font-size: 12px; line-height: 16px;">THIS is why Citroen fails in quality surveys, its after sales service directly and through dealers is pants!

</td><td valign="top" ="msgabletop"="" style="height: 15px;">
</td></tr></t></table>

Edited by: rich.cath
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #7 ·
Citroen are having a laugh.Been into dealer again as he had'nt contacted me in a week since last had car and took more tests.
Wants it in again to take more codes/tests - this is a known problem and they are just trying to hide it.
Apparantly they cannot replace unit as this won't solve problem - it is software related and needs to be bespoke to each car as the combinations you could have cause standard fixes to compound errors.
So still waiting........
 

·
Registered
Joined
·
39 Posts
I had my first problem with unreadable CD - the unit was changed. Interesting experience was see the logo of Peugeot after change of CD/NAVI unit on my screen :). I had to wait to new unit, because it was fault. Now I have a problem with reseting of my system, but for this moment it isn't too often. I don't know if it is normal sometimes (once per month during everiday driving).
 

·
Registered
Joined
·
43 Posts
I have already posted elsewhere on the forum, but think here a bit more relevent.
Since delivery in December (even failed at the dealer when I collected the car), the emyway system on occasion fails to work on start up, just showing 'Citroen' home page.
The latest software update was carried out on the weekend but the problem is still there.
My dealer wants to remove the unit and send it back to Citroen, at least supplying me a courtesy car.
Has anyone had any update as to a proper cure for this issue?
Kind regards
Keith
 

·
Registered
Joined
·
472 Posts
I have had the software update and it worked, normally the unit is now on within 10 - 15 seconds, the only time it takes longer is when I am in a garage when it has difficulty finding a satellite then it can take up to 30 - 45 seconds
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #11 ·
Unfortunately there is no 'simple' fix and persistant nagging is all you have.

I have had a problem that is linked to the Emyway system or the ECU for 13 months and the dealer won't change unit without Citroens approval and Citroen have tried everything to avoid doing it.
I had the blank screen at start-up as well as numerous problems and eventually a 'fix' was produced (after it hit a national car mag), which seemed to eliminate that, but obviously bypasses some functions at start-up as I don't get told of ice alerts,and my TPMS system says all okay (even though my winter wheels have no sensors!), until I have been going for 40 mins or so - the question is what else is not working at start-up ABS, ESP - Citroen have no clue, and I'm now threatening them with VOSA, Watchdog and bad publicity again.

Hope you have better luck.
 

·
Registered
Joined
·
38 Posts
I've already posted this but to put in my two pennies worth;

Dealer collecting my car tomorrow and being supplied a courtesy car through Citroen uk, I contacted them myself. My emyway system constantly reboots every 10 seconds, local dealer cannot solve, they will keep the car until it is resolved, hopefully not too long, had previous problems with ipod connection through usb, again kept rebooting when listening to certain tracks within a play list, my warranty expires in June this year, getting a little nervous as after this date, I'm on my own. Lost confidence in the car and dealer...

Yesterday, headlight bulb warning shown on dash, tried to replace the headlight bulb myself as it had stopped working, tried to get the connection off the back of the bulb and it started working again, was warned years ago about Citroen electronics but thought they'd have cracked it by now, evidently not..
 
1 - 12 of 12 Posts
Top