Citroen DS4 Forums banner
1 - 20 of 21 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi All,

I have a problem with the sound system, it plays CD's, you see the tracks playing and you can change track, also the USB input works I can see it play the tracks and I can change track, same with the radio. But there is no sound, the parking sensors don't give a warning when you are close to an object either.

I have checked the 10 A Hi-Fi amplifier fuse and it looks good, also double checked with a spare fuse and same thing. (The mute is not on!).

My car is the DS4 2012 sport, any suggestions would be welcome.
 

·
Registered
Joined
·
1 Posts
Hi there I have had the same problem for months. Its really frustrating. Its been off for months and then all of a sudden it comes back on for a few days then goes again. I would also be very interested if somebody could shine some light on the matter.
 

·
Premium Member
Joined
·
937 Posts
Have either of you discussed this with Citroen or your prospective Dealer's?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I am going today or tomorrow, I was just wondering if anyone has had the problem and what the solution is.
 

·
Premium Member
Joined
·
937 Posts
I wish I could help GavGood luck with the Dealer
 

·
Registered
Joined
·
3 Posts
I I'm new here and all the sudden my 2011 DS4 does not play any sound trough the speakers.

Everything works, I see it on the screen, GPS, CD player, parking sensors, etc... but, no sound!


Does anyone figure it out or have any fiz done by the dealer?


Thanks.
 

·
Registered
Joined
·
3 Posts
I took the DS4 to the dealer and after a day, they said to me that there's a problem with the radio and a new unit is the only option.

They said that they tried everything... but with no success.


Ask them what is the problem... they don't know, they only know it's the radio unit... I insist... if there's a problem you have to know specifically what it is!? No, we don't know we can't open the radios.


To say that I am pist off is to little...


I have bring the car as it is and will try to sort the problem by other means.


If someone as any input on this, please share.
 

·
Registered
Joined
·
1 Posts
Hello everybody,

Just bought a DS4 (model 2012) today and I seem to have the same problem...
Is there any new news about this NO SOUND issue?


Sometimes it works when you start the car and sometimes not. Everything seems to work normally but no sound.
 

·
Premium Member
Joined
·
937 Posts
Hello Roy
Welcome to The Owners Club
I'm afraid there are no more posts on the Issue since last year!!
This is the inherent problem with Car Forums...Someone posts an issue and then doesn't follow up with any more information
You will have to take it back to the Dealer...in the absence of a reply
 

·
Registered
Joined
·
2 Posts
Problem is most likely a defective speaker if u got the Denon Sound System the amplifier will cut the power to all the Speakers.

I got it on mine and had an error code for that stored.
 

·
Registered
Joined
·
6 Posts
i have replaced all the speakers and nothing changed still the sound goes on and off and the left hand side speakers are more weaker then the right hand ones. And also the temp sensor does the same sometimes show me the outside temp dometimes dont.
Any suggestion any advice please Help
Help
 

·
Registered
Joined
·
492 Posts
Hi there,
your describing electrical faults and without a wiring diagram I'm only guessing but I'd say that because the in car display/ entertainment unit is linked to the external temperature sensor, your sensor is probably OK just that it is not been being understood by your faulty cd radio unit. I had a similar problem with my previous Peugeot 307 where the dealer said the entertainment unit was faulty and non repairable.
Sorry to say I replaced it with a more capable Kenwood unit, for a 1/4 the cost of the Peugeot replacement.
 

·
Registered
Joined
·
6 Posts
Thaks for your reply. I might buy a used radio unit. The trouble is if i buy an aftermarket unit I have to make loads of modifications. I have steering wheel radio controls and loads of stuff like dashboard computer bluetooth which are conneted to the radio.
I am not sure if i buy an aftermarket unit i can keep all these extras
 

·
Registered
Joined
·
492 Posts
Now I think about it, the 307 had some Intermittent issues with electrical bits that was traced back to a cracked fuse box.
Who knows how it cracked as the car was never in an accident but if your up for it...take a good look, really examine the engine bay fuse box for cracks or loose connections.
Unless you've got a covered dry space to work on the DS, I'd say let a qualified garage/dealer track it down for you. They'll know how to isolate areas and narrow down the possibilities. Come back with your findings / the outcome.
 

·
Registered
Joined
·
3 Posts
did you ever get this fixed?

Hi,

A few months ago i purchased a ds4 , and i have the same audio issues described in this thread. Did you ever get this resolved?

Any info would be greatly appreciated

Thanks
Steve
 

·
Registered
Joined
·
1 Posts
had the same problem - they fix it

Hi Guys,
after a few years of working/not working sound system, we found the problem and the solution!

History:
My Citroen's DS4 Denon sound system suddenly stopped working while riding on the reverse. ;-). I crashed a little as I was just waiting for the sound :-/. From that time the sound was not working during hot temperature but it was working while freezing weather. Or it suddenly starts working after 30-40 minutes. Half-year ago sound system totally stopped working.

Repair:
I put the car to a dealer to ask him to do everything. I know that they do a very good job. They found out that:

1. the common problem with DS4 is water coming to the rear doors very often
2. the water came to the speaker which short circuit
3. I was very lucky as the amplifier was ok; they told me that it is very often that when the speaker is short circuit, the amplifier can short circuit also!

Radek
 

·
Registered
Joined
·
5 Posts
Am a Citroen ds4 2.0 hdi 2015,with Denon sound system... the sound is not there. The dealer replaced the radio, the sound came back and died on the 3rd day. The dealer suspected the amp, now am in south africa, the amplifer has been out of stock for 6 months now in France apparently. So i opted for after market... now the volume cannot be controlled and the sensors are quiet. I have installed 4 channel Jbl amplifyer and sub. Help a lady out please... am frustrated.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top