Citroen DS4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
hi guys , im new on here just bought a 13 plate ds4 1.6hdi style 25.5.15 since I have taken ownership the car has been pinking and has no power up to 2000rpm when cold , car has been in citroen for 5 days , I picked it up yesterday and this morning the same thing has happened , I took it to my usual garge who done a diagnostic and it showed egr fault, took it back to citroen who showed me a tech issue saying a software up date sorts the issue but still shows egr fault, have any of you guys had this, I think the egr is still at fault but they say it is not, I cant believe the ecu would have a permanent fault and allow the car to run ok as they say. anyone heard of this or can clarify it, thanks in advance.Graeme
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
according to Edinburgh citroen the data has been handed over to citroen technical, so hopefully they can get to the root of the problem, do we have any mastertechs on here that have had similer problems???
 

·
Registered
Joined
·
16 Posts
Hi there did you get any joy with this problem. Mine did the same when I bought it 18 months ago and they added some of their "special??"diesel additive and that appeared to sort the problem. However recently and particularly whenI use supermarket fuel the problem has come back and even when using Shell dieselit can still sound very rattleysometimes (generallythe noise isn't as bad with Shell fuelbut still not great). I presume it's related to fuel quality and maybe mileage, maybe sticky injectors from poor quality fuel giving deposit build up on the injectors, or possibly MAF meter? Sounds like it's pinking but that shouldn't happen with diesels so not sure what the problem is.
On a long run it's great but after a few days back home theproblem returns. Searching the internet some owners suggest Millers additive, has anyone tried this?

Really annoying and I'm getting poor fuel economy as well so doesn't feel right, (maybe they've got the same emissions controlsystem as VW? so I shouldn't expect better :) )
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Car is fixed now. After replacing all four injectors the problem went away for a few weeks. But came back and Citroën Edinburgh done a software update. But it never worked so Citroën technical done another update remotely from down south and appears to have solved the problem. That was around four months ago and it's still OK now. So fingers crossed. Also got two alloys replaced due to corrosion.
 
1 - 5 of 5 Posts
Top