Citroen DS4 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi all

Would just like a bit of info.

I have a 4 month old DS 4 1.2 Prestige.

Is it normal for the "Service" to show for a very short time once I have pressed the "Start" Button?

Can't remember if it has done it all the time, it is currently red but I seem to think it was orange a couple of days ago.

I pressed the Spanner Button while the engine was running but it said everything was ok.

It did show the next service time but it should not be until the coming November.

Thanks in advance.
 

·
Registered
Joined
·
544 Posts
Perfectly normal, it has to do this as part of the 'check' process to prove the systems work as they ought to.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thank you very much for the prompt response.

That is what I thought it was doing.

Normally you only see the "Service" light on some models when it actually gets near to a service.

I had a VW Bora only shown the Service due notice a couple of months before the service was due.
 

·
Registered
Joined
·
544 Posts
The 'Service' warning on the DS4 (and PSA cars for that matter) does not mean it is due a service, it's a warning that there is a fault and it needs to be taken in to service (a dealer), the regular service warning light is actually a little spanner that comes on one month or 1500 miles from the due service
 

·
Registered
Joined
·
2 Posts
Hi I've just got a ds4 (64 plate ) 1.6,my service light has just started coming on just before I start car and I've noticed in the 4 days that I've had the car when I turn off the car the fan continues to run for 30 seconds or so after , not every time but quite a few times
Any advice?
 

·
Registered
Joined
·
492 Posts
The fan continuing to run sounds like normal operation to me as that's the way mine behaves.
 

·
Registered
Joined
·
201 Posts
Lisaann said:
Hi I've just got a ds4 (64 plate ) 1.6,my service light has just started coming on just before I start car and I've noticed in the 4 days that I've had the car when I turn off the car the fan continues to run for 30 seconds or so after , not every time but quite a few times
Any advice?
I'd say it sounds normal. My orange service light comes on also as part of the preflight check, then goes off.
 
1 - 9 of 9 Posts
Top