Citroen DS4 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Picked my DS4 DSport at the weekend, and very pleased with it...!

One minor gripe... The 'Traffic' button seems to bring no information down on traffic conditions - there are never any stations listed. I spoke to my dealer and they didn't really seem to know why it should not be working, but they're going to look into it and get back to me.


Anyone else having the same problem? Or even better, know how to get it working!


Cheers, James
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Thanks for the responses so far...

Yes - I have the built in SatNav and also the DAB radio (I have a feeling it may be relate to DAB, but that's a guess!)
 

·
Registered
Joined
·
578 Posts
There is a soft ware update that your dealer should know about I had it done about 12 months ago and been fine since.

Get to your dealer and moan
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
Thanks.. I'll give them a call now...

You would have thought that when they sell a brand new car, they would check it had the latest software on it!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
Interesting... just had the latest software (I think!) and still no traffic...

My only thought is that maybe they only updated the maps, not the actual eMyWay software - does anyone know how you can check your eMyWay software version?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
I'm sitting in the dealer right now while they look at the car... they still seem unsure but are trawling though the Lexia settings to see if they can locate a configuration issue.

Does anyone know exactly what update is required to get this working?


Thanks!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #9 ·
Good news... it's finally fixed!

For interest, and if anyone else experiences the same issue, a TMC update is what was required.


When you press setup for a few seconds you can view your various software levels - the relevant setting is 'Grpo4: 403' - the update takes this up to level 405, which fixes the problem.
 
1 - 9 of 9 Posts
Top