Citroen DS4 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi all, I rarely use the massage seats but do remember that when I have tried them in the past they felt really good and felt like they gave a good 'push' in the back.

However, I went to use them again the other day and I could hardly feel them at all, certainly couldn't feel any pressure.

Has anyone else ever had this? I dont think i have adjusted my seat that much so cant think what it could be
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
GrandClown said:
Instead of sitting on them put your hands there, press in hard and see if you can feel anything.
I can feel something when sitting down, its just very faint opposed to a really strong push that I used to get
 

·
Premium Member
Joined
·
936 Posts
Have you tried putting the lumbar support up to maximum before you turn on the Massaging Function?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Just revisiting this one again!

Yes ive tried the lumbar to maximum one way and the other. Also just tried sitting in the passenger seat and that one doesnt seem very strong either.

I definately remember when test driving the car that it was very strong, almost digging in my back now they just seem pointless.

Is there anything elsewhere in the car that could be causing it to lack power? Not necessarily a fuse but something similar?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top