Citroen DS4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all, I bought a 2012 DS4 DSport brand new from the dealer about 6 months ago, and there's been a weird noise that it makes ever since I got it. It's not causing any actual problem so I haven't been too worried about getting it looked at, but I wanted to see if it's normal or something I should actually be concerned about.

Basically, after you've been driving for about 10-15 minutes and the engine has warmed up (I guess), then pretty much whenever you accelerate and put the engine under load it makes this odd rattle/vibration/ticking kind of sound. It's not particularly loud, and it seems to come right from the center of the engine area, at least that's how it sounds from the driver's seat. As soon as you back off the accelerator it stops.

Not having owned a car with a turbo before, I don't know if this is something normal for those, or if it's some known quirk with the DS4.

Can anyone enlighten me on this? Should I be concerned about it?

Cheers,
Adam
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hi,

No, I never did figure it out. I got a suggestion that it might have been due to using lower quality fuel, but switching to using 98 octane didn't make any difference.

It hasn't gotten any worse so I pretty much ignore it now, but whether there is some underlying problem that will eventually cause a major problem? I guess I'll just have to wait and see.

Cheers,
Adam
 

·
Registered
Joined
·
6 Posts
I don't think it is the egr, it seems to be something loose under the dash, like a fan rattle, from time to time, the engine works fine
 

·
Registered
Joined
·
13 Posts
angheaa,

My wife's c3 has a bad "rattle" when she accelerates while the air-con is on. It's like the fan is hitting something. No air-con, no rattle. Is it the same with yours?

I think it's a real pain to fix, so we haven't bothered.
Doyley.
 

·
Registered
Joined
·
16 Posts
Hi there, had the same problem when I bought mine 18 months ago. Dealership put some of their "dogs bo****ks" fuel additive in and it disappeared. Have been using Shell diesel since then and it has been OK. Put some Morrison's diesel in a couple of months ago and noise came back?? fuel quality issue maybe?? bit of internet searching and recommendation was to use (Millers ecomax additive, I think that's what it's called). So bought some and noise has gone away again. Worth a try if nothing else, buy off the internet, half the price of leading high street store.
If this doesn't help then maybe faulty fuel injectors which should be sorted under warranty. Good luck.

A
 
1 - 7 of 7 Posts
Top